Version 1/2 - Next ยป - Current version
admin, 20/03/2012 14:20


LibMTDev Multitouch Support

(!) Note: (!)
This is legacy support. Ubuntu 11.04 and above support XInput 2.1, which needs no configuration and should work out of the box if you have a multitouch device which is supported by the Linux Kernel.

These are some notes on how to get libmtdev multitouch support running with libavg:

  • Find out which name(s) the multitouch device you have goes by:
$ xinput list
  • Tell X11 to ignore any multitouch devices you have. To do this, add something similar to the following in /etc/X11/xorg.conf, substituting the correct product name(s):
Section "InputClass" 
    Identifier "Trackpad" 
    MatchProduct "Apple Wireless Trackpad" 
    Option "Ignore" "on" 
EndSection
  • Restart X11.
  • Find out which device file the multitouch device is mapped to. You can cat all /dev/input/event* files until you find one that spews out stuff when the device is used.
  • Make sure the device file is accessible:
$ sudo chmod a+r /dev/input/eventxx
  • Set necessary environment variables:
$ export AVG_MULTITOUCH_DRIVER=LINUXMTDEV
$ export AVG_LINUX_MULTITOUCH_DEVICE=/dev/input/eventxx

If you get

WARNING: Unsupported multitouch driver 'LINUXMTDEV'.

then you need to recompile libavg with libmtdev-dev installed.